Recommended Internet Browsers for This Site

Certain LETOA website features such as the Training Calendar will NOT display properly when Internet Explorer version 8.0 or earlier versions are used.

Internet Explorer users may correct these display issues by updating their browser to Internet Explorer version 9.0 or above.

Display issues may also be corrected by viewing the website with Google Chrome or Mozilla Firefox Internet browsers.